Hacking the XP POS updates

Hacking the XP POS updates

Postby lioninstreet » 08.03.2020, 06:11

Since the answer to this may not involve using WSUS off line at all, this is a bit of an out of the box question I'm going to ask. But if anyone has the knowledge, it's someone here.

I'm playing with WHSv1, attempting to figure out how to get the Windows Embedded POS2009 updates to install on it. I've downloaded them all and tried a manual install of one or two, but the system throws a pop up stating it's not applicable.

I've also tried the obvious. First on a fully updated WHSv1 OS (thanks to Aker), I made the XP POS registry edit thinking maybe WUMT might simply identify & install the POS updates like it does on XP. Of course, no luck. Window's update won't do it either.

So here's the question. How does Windows recognize if an update is applicable to the OS it is being installed on, and would it potentially be possible to do a direct hex hack to a XP POS update so it would install on WHSv1 (or S2k3r2 for that matter)?

If this sounds like it might be possible (or at least worth trying), would any of you guys here be able to give me a little arrow pointing how to do it?
lioninstreet
 
Posts: 103
Joined: 21.06.2018, 00:06

Re: Hacking the XP POS updates

Postby aker » 08.03.2020, 09:56

Things like the POSReady-hack are unsupported here.
That's why I'll close this topic.

It's not possible to install the POSReady-updates to WHS v1 as POSReady 2009 is based on Windows XP (= Windows NT 5.1) and WHSv1 is based on Windows Server 2003 (= Windows NT 5.2).
Wer Rechtschreibfehler findet, darf sie behalten oder an den Meistbietenden versteigern. / Everybody finding a misspelling is allowed to keep or sell it.
aker
aker
 
Posts: 3616
Joined: 02.03.2011, 15:32


Return to Verschiedenes / Miscellaneous

Who is online

Users browsing this forum: No registered users and 6 guests