Determineation of OS properties failed

Determineation of OS properties failed

Postby Lopmig » 03.07.2019, 18:06

Hello all,
I tried running WSUS on an air gapped machine and when I run the UpdateInstaller.exe the cmd prompt pops up and I get an error: "Determination of OS properties failed". I looked on the net for solutions but could not find anything. Any help would be appreciated and if you do have a solution please let me know with step by step instructions I'm a bit of a Novice to WSUS and to IT related items at times.

Ran the .exe file directly as admin, logged into the machine as Admin, Used an elevated cmd prompt, the WSUS files are on the machine directly and not on a USB or disc,
Posts: 3
Joined: 11.04.2019, 13:30

Re: Determineation of OS properties failed

Postby Dalai » 03.07.2019, 18:43

Please check if Windows Script Host has been disabled, and if WMI (Windows Management Instrumentation) is working correctly. To do the former, check the following registry keys:
Code: Select all
HKLM\Software\Wow6432Node\Microsoft\Windows Script Host\Settings
HKLM\Software\Microsoft\Windows Script Host\Settings
HKCU\Software\Microsoft\Windows Script Host\Settings
for a setting/value named Enabled (and data set to 0).

To do the latter, please run WMIDiag.

Posts: 1021
Joined: 12.07.2016, 21:00

Return to Installation / Updating

Who is online

Users browsing this forum: No registered users and 34 guests