Error installing updates

Error installing updates

Postby DaveN » 19.06.2017, 18:00

Windows 7, all downloads worked AOK for Win7 and o2k7.
Ran UpdateInstaller.exe and it proceeded OK until it hung while Installing ..\cpp\vcredist2010_x86.exe...

Restarted UpdateInstaller.exe
Now I get a warning and the redistribution files are not installed.

Code: Select all
Verifying integrity of ..\cpp\vcredist2010_x86.exe...
hashdeep.exe: Audit passed
Installing ..\cpp\vcredist2010_x86.exe...
Warning: Installation of ..\cpp\vcredist2010_x86.exe failed (errorlevel: 5100).

Subsequent installs are proceeding normally.

What's happening, and how can I get this to work?

Best Regards, Dave

Re: Error installing updates

Postby Dalai » 19.06.2017, 19:25

I didn't find any relation to error code 5100 so far. This thread on StackOverflow discusses several potential causes for this error, despite being initially about .NET Framework.

When did you last run the download part of WSUS Offline (UpdateGenerator)? Maybe the vcredist2010_x86.exe file is older than the one already installed on your system (as the linked thread suggests)?

Posts: 1021
Joined: 12.07.2016, 21:00

Re: Error installing updates

Postby DaveN » 19.06.2017, 20:01

I downloaded your latest wsusoffline and ran it this morning.
It downloaded this file this morning...

Re: Error installing updates

Postby boco » 20.06.2017, 00:01

Did you try to run it manually? Usually it will display a more precise error message, then.
Microsoft update catalog:
Windows Install media download:
Posts: 2320
Joined: 24.11.2009, 17:00
Location: Germany

Re: Error installing updates

Postby DaveN » 22.06.2017, 15:55

Oddly, when I ran patch manually, it said it "repaired" install.
Listing installed updates now shows it twice, latest entry with manual run date, and version number identical in both entries.

Anyway, repeatedly rebooting and rerunning UpdateInstaller eventually got the VM sorta up-to-date.

Windows Update now runs, but unfortunately installing any patches with Windows Update results in the VM not being able to start Windows!
Windows start failure claims "A required device is not available" or some drivel.
Aaarrggg.... At least I got all the security patches installed (I think)...
Reminds why our customers are trying desperately to move away from Windows wherever possible.

Thanks for your great utility!
Best Regards, Dave

Re: Error installing updates

Postby hbuhrmester » 22.06.2017, 17:27

The UpdateInstaller.exe returns error codes as decimal numbers. Try changing them to hexadecimal numbers and padding them to 8 digits, e.g.

Code: Select all
5100 = 0x000013EC

This may return some more results: ... netfxsetup ... netfxsetup
Posts: 459
Joined: 11.10.2013, 20:59

Return to Installation / Updating

Who is online

Users browsing this forum: Google [Bot] and 22 guests