Probleme bei Dotnet-updates

Probleme bei Dotnet-updates

Postby Denniss » 05.02.2011, 14:03

Auf einem XP-Home-System:
Nach der Installation von ndp1.1-kb2416447 führt der Rechner einen Neustart durch, das Update wird in der Systemsteuerung aber als installiert angegeben und lässt sich auch deinstallieren. - Fehlende Neustartunterdrückung
Bei NET2.0 ohne SP werden keine Updates erkannt/installiert obwohl das auch über Autoupdate angebotene ndp20-kb928365 im Ordner dotnet-x86-glb vorhanden ist. Gleiches auf Server2003. Der MSBA moniert das Fehlen dieses Updates ebenfalls.
Bei Net3.0 ohne SP wird ndp20-kb928365 nicht erkannt/installiert, wird vom MSBA angemahnt und erscheint per Autoupdate.
->mögliche Fehlerursache: Net2.0 erscheint nicht in der Liste der installierten Software, erst nach manueller Installation von 928365 ist ein solcher Eintrag vorhanden ?!?

Bei Vista gibt es ein Problem bei der Installation von kb2416470, trotz laut log erfolgreicher Installation (wird auch in der Systemsteuerung als installiertes Update gelistet) wird es sowohl über Windoofsupdate wieder angeboten als auch mittels WOU erneut installatiert (bei einen Kontrolldurchlauf nach der großen Installation).
Der MSBA moniert es ebenfalls als fehlend.

Diese Probleme sind bei meiner verschlankten Version aufgetreten, dürften aber nicht davon verursacht sein da diese Updates nirgends ausgeschlossen sind. Beim Durchlauf des Update Installers erscheinen diese auch nicht als fehlend/blacklisted.
Denniss
 
Posts: 868
Joined: 01.08.2009, 10:51

Re: Probleme bei Dotnet-updates

Postby Denniss » 12.02.2011, 15:43

Die Probleme mit kb2416470 bestehen neben Vista x86 auch in der x64-Version. Unter W2k8-x86 trat es ebenfalls auf.
Unter W2k3-x64 gibt es auch wieder das Problem mit Net2.0 ohne SP (diesmal in x64), das Update ndp20-kb928365 wird vom Installer nicht als fehlend erkannt, wohl aber vom MSBA.
Denniss
 
Posts: 868
Joined: 01.08.2009, 10:51

Re: Probleme bei Dotnet-updates

Postby Denniss » 12.02.2011, 21:09

Bei W2k3-x64 bin ich auf ein Problem gestoßen, das ich mit der dotnet4-Installation in zusammenhang bringe.
In diversen Vorinstallationen mit Neustart wurden IE7 und Dotnet 3.5 SP1( mit Updates in einem Rutsch) installiert. Beim nächten Aufruf des Installers hat er mir Dotnet4, die Powershell 2.0 und die ganzen fälligen Updates installiert. Seitdem ist das System unwahrscheinlig träge und diverse Programme wie der IE brauchen mehrere Minuten zum Starten.
Der dann von mir wieder aufgerufene Update Installer verabschiedet sich seitdem immer mit "unsupported OS language".

Ich werde das nochmal nachstellen um den Verursacher einzukreisen - mich wundert nur das nach der dotnet4-Installation kein erneuter Neustart angefordert wurde.

Update: Ein großes Maß an Trägheit und Startverzögerung Trägheit wird von dotnet4 verursacht, warum auch immer. Es ist kaum Plattenaktivität zu sehen und auch im Taskmanager ist nichts. Wenn dann die Netzwerkverbindung erscheint, läuft auch das System halbwegs. Das Problem mit der Unsupport OS labnguage ist bisher nciht wieder aufgetreten.
Denniss
 
Posts: 868
Joined: 01.08.2009, 10:51

Re: Probleme bei Dotnet-updates

Postby WSUSUpdateAdmin » 16.02.2011, 16:16

Moin!

Bzgl. kb2416447 vgl. viewtopic.php?f=2&t=673.
kb2416470 sehe ich mir an, solche Effekte gab's aber schon häufiger.
Bzgl. WOU vs. MBSA: Wurde letzterer im Offline-Modus ausgeführt, d.h. mit wsusscn2.cab als Katalog/Datenbasis?
Das ist ja ein nicht unerheblicher Unterschied...

GTW
WSUSUpdateAdmin
Administrator
 
Posts: 2245
Joined: 07.07.2009, 14:38

Re: Probleme bei Dotnet-updates

Postby Denniss » 16.02.2011, 17:37

MSBA: Wird ganz normal als Programm installiert und dann einmal benutzt um den Sicherheitskatakog herunterzuladen. Danach ist die VM in der Regel Offline.

Zum Nachstellen des ndp1.1-Patches: WXP installieren, dann Net 1.1 drauf. Beim Durchlauf des WOU sollte Net 1.1SP1 installiert werden. Nach Durchlauf einen Neustart durchführen und WOU nochmals ausführen um den fraglichen ndp1.1-patch zu installieren und schon kommt der ungefragte Neustart.
Denniss
 
Posts: 868
Joined: 01.08.2009, 10:51

Re: Probleme bei Dotnet-updates

Postby WSUSUpdateAdmin » 16.02.2011, 19:34

Denniss wrote:MSBA: Wird ganz normal als Programm installiert und dann einmal benutzt um den Sicherheitskatakog herunterzuladen. Danach ist die VM in der Regel Offline.

Ok.

Denniss wrote:Zum Nachstellen des ndp1.1-Patches: WXP installieren, dann Net 1.1 drauf. Beim Durchlauf des WOU sollte Net 1.1SP1 installiert werden. Nach Durchlauf einen Neustart durchführen und WOU nochmals ausführen um den fraglichen ndp1.1-patch zu installieren und schon kommt der ungefragte Neustart.

Ja, danke.
Es geht hier aber eigentlich nicht ums Nachstellen. Dass dieser Effekt auftritt oder auftreten kann, ist unbestritten. Es geht darum, dass ich dagegen nichts tun kann!
Wie man dem Posting von wwsmith ( :arrow: viewtopic.php?f=2&t=673&start=10#p3241) und dem dort verlinkten Beitrag (http://social.answers.microsoft.com/For ... e934f5d7ea) entnehmen kann, ist das offenbar ein Problem von Microsoft.

Wenn ich das Update mit dem für dieses Update gültigen Parameter (hier: "/q" (Stiller Modus, ohne Benutzereingriff.)) installiere und das System unaufgefordert neu startet, bin ich 'raus.

Was soll ich dagegen machen, außer vielleicht
Code: Select all
if "KB2416447" (
  rem *** Schlimmer workaround, weil Microsoft ein Matschpaket ausgeliefert hat ***
  ...
)

:?:
Nee, ich glaube, lieber nicht...

Gruß
Torsten
WSUSUpdateAdmin
Administrator
 
Posts: 2245
Joined: 07.07.2009, 14:38

Re: Probleme bei Dotnet-updates

Postby WSUSUpdateAdmin » 16.02.2011, 21:39

Entschuldigung, ich war genervt.

Ich habe bei
Code: Select all
ndp1.1sp1-kb2416447-x86_dbcfdff0a6b77cbfdc4ba009e2940bfad5e94e85.exe /?

folgendes überlesen:
Code: Select all
Die folgenden Optionen werden zusätzlich zu den vorhandenen Windows(R) Installer-Befehlszeilenoptionen zur Verfügung gestellt. Wenn Sie weitere Informationen über Windows Installer-Befehlszeilenoptionen wünschen, führen Sie den Befehl "msiexec /h" aus.


Fix für kb2416447: http://trac.wsusoffline.net/trac.fcgi/browser/trunk (r213).
Nix für ungut (hoffentlich),

GT
WSUSUpdateAdmin
Administrator
 
Posts: 2245
Joined: 07.07.2009, 14:38

Re: Probleme bei Dotnet-updates

Postby -Iwan- » 16.02.2011, 21:50

Ich versteh es langsam auch nicht mehr, was MS da für einen Mist abliefert.
In der Firma nutzen wir ein Fremdprodukt zum direkten Update der Rechner nach einer Neuinstallation.
Dabei starten 85% der Rechner mittendrin einfach neu und es geht jedesmal um ein .NET-Update.
Da kann man echt nur verzweifeln... :cry:
-Iwan-
 
Posts: 364
Joined: 02.11.2009, 17:49
Location: NRW, Germany

Re: Probleme bei Dotnet-updates

Postby Denniss » 16.02.2011, 23:06

Nur mal so zum Versändnis - wofür ist die OptionList-Q.txt eigentlich ?
Hängt die bei den Installationsroutinen noch ein /q für quiet dran?
Denniss
 
Posts: 868
Joined: 01.08.2009, 10:51

Re: Probleme bei Dotnet-updates

Postby boco » 17.02.2011, 00:30

Soweit ich weiß, legt diese Datei fest, welche Updates die entsprechende Option unterstützen.
Microsoft update catalog: http://catalog.update.microsoft.com/v7/site/
Windows Install media download: https://support.microsoft.com/en-us/help/15088/windows-create-installation-media
boco
 
Posts: 2279
Joined: 24.11.2009, 17:00
Location: Germany

Next

Return to Fehlende Updates / Missing updates

Who is online

Users browsing this forum: No registered users and 1 guest

cron