CreateISOImage überarbeitet

CreateISOImage überarbeitet

Postby hhullen » 11.03.2013, 14:28

Hallo, alle miteinander,

ich habe (vor allem) CreateISOImage.sh kräftig überarbeitet; scheint derzeit (genauer: sobald Torsten die neue Version eingearbeitet hat) in sich brav zu funktionieren.

Vorab: CreateISOImage.sh und DownloadUpdates.sh benutzen in der neuesten Version beide das Inklude-Skript "commonparts.inc". Wer sich die überarbeiteten Teile einzeln aus dem "trunc" holt, der muss bitteschön auch diese Datei nach "sh" kopieren - sonst gibt es (natürlich) eine Fehlermeldung.

Hintergrund dieser Änderung: beide Skripts benutzen einige (längere) Teile in gleicher Weise, da ist es sinnvoll, sie zum gemeinsamen Zugriff auszulagern.

Erzeugung eines *.iso-Images: da hat Torsten auf der Windows-Seite im Lauf der Jahre einige Schmankerl eingebaut, die bisher noch nicht ihren Weg auf die Linux-Seite gefunden haben. Derzeit wird so etwa das gesamte "client"-Verzeichnis übernommen, das Ausblenden von nicht gewünschten Windows- oder Office-Versionen muss ich noch mal studieren und zu übersetzen versuchen. Derzeit wird also eventuell eine sehr grosse DVD benötigt.
Viele Grüsse
Helmut
hhullen
 
Posts: 100
Joined: 23.04.2012, 11:43

Re: CreateISOImage überarbeitet

Postby WSUSUpdateAdmin » 12.03.2013, 18:36

Danke für Deine Arbeit, Helmut! :)
:arrow: http://trac.wsusoffline.net/browser/trunk (r454).
GT
WSUSUpdateAdmin
Administrator
 
Posts: 2121
Joined: 07.07.2009, 15:38

Re: CreateISOImage überarbeitet

Postby ronald » 04.04.2013, 17:15

Hi

supi das das mit Linux weitergeht :-)))
Danke.

Aber, leider...

irgendwie wundert mich, das ich "neuerdings" (8.0?) beim parameter "glb" fehlermeldungen bekomme.

Ich musste "enu" angeben, damit überhaupt was gebaut wird.
Nun (8.3) geht auch das nicht mehr.

Code: Select all
./DownloadUpdates.sh w61 enu /makeiso /dotnet /msse /wddefs /nocleanup /proxy http://127.0.0.1:8080

läuft, nach laaaanger Zeit kommt dann
Code: Select all
#########################################################################
### WSUS Offline Update ISO maker for Linux systems ###
### v. 8.3 ###
### ###
### http://www.wsusoffline.net/ ###
### Authors: Stefan Joehnke, Walter Schiessberg ###
### maintained by H. Hullen ###
#########################################################################
language glb does not exist.

(man beachte: ich habe "enu" angefordert und "glb" wird angemeckert)

Dieselbe meldung kommt allerdings sofort, wenn ich anstelle "enu" "glb" eingebe.

Was ist das?

Beim "maken" mit "enu" sehe ich auch laufend das Token "-glb".
Wie ist denn nu richtig?

Ich dachte win7 sei sprach unabhängig?


Ich habe "glb" mal wieder in die liste der language gepackt, dann scheint es zu laufem.
ich bekomme da zumindest iso raus und das update scheint zu rennen...
Code: Select all
wsusoffline/sh# vi commonparts.inc
langlist="enu deu nld esn fra ptg ptb ita rus plk ell csy dan nor sve fin jpn kor chs cht hun trk ara heb"
--->
langlist="glb enu deu nld esn fra ptg ptb ita rus plk ell csy dan nor sve fin jpn kor chs cht hun trk ara heb"

Code: Select all
#########################################################################
### WSUS Offline Update Downloader for Linux systems ###
### v. 8.3 ###
### ###
### http://www.wsusoffline.net/ ###
### Authors: Tobias Breitling, Stefan Joehnke, Walter Schiessberg ###
### maintained by H. Hullen ###
#########################################################################
Your choice
System: w61
Language: glb
Parameter: /makeiso /dotnet /nocleanup /msse /wddefs
Proxy: http://127.0.0.1:8080

Thank you - now I start working!
Downloading most recent Windows Update Agent and catalog file...
wget -nv -N --timeout=120 -i ../static/StaticDownloadLinks-wsus.txt -P ../client/wsus
Determining static URLs for w61 glb...
Extracting Windows update catalogue file package.xml...
../client/wsus/wsusscn2_1.cab: WARNING; possible 16040 extra bytes at end of file.
Found valid list of superseded updates...
Determining update URLs for w61 glb...
ronald
 
Posts: 7
Joined: 04.04.2013, 16:56

Re: CreateISOImage überarbeitet

Postby hhullen » 06.04.2013, 16:01

ronald wrote:Hi

supi das das mit Linux weitergeht :-)))
Danke.

Aber, leider...

irgendwie wundert mich, das ich "neuerdings" (8.0?) beim parameter "glb" fehlermeldungen bekomme.

Ich musste "enu" angeben, damit überhaupt was gebaut wird.
Nun (8.3) geht auch das nicht mehr.

[...]

Ich habe "glb" mal wieder in die liste der language gepackt, dann scheint es zu laufem.

[...]

[/code]


Hmmm - seltsam!
Sowohl der Fehler als auch die Korrektur.

Mal sehen, wo dieser Wurm steckt.
Viele Grüsse
Helmut
hhullen
 
Posts: 100
Joined: 23.04.2012, 11:43

Re: CreateISOImage überarbeitet

Postby hhullen » 10.04.2013, 15:49

ronald wrote:Hi

supi das das mit Linux weitergeht :-)))
Danke.

Aber, leider...

irgendwie wundert mich, das ich "neuerdings" (8.0?) beim parameter "glb" fehlermeldungen bekomme.



Weil die Sprache inzwischen etwas pingeliger geprüft wird ...

ronald wrote:Ich musste "enu" angeben, damit überhaupt was gebaut wird.
Nun (8.3) geht auch das nicht mehr.

Code: Select all
./DownloadUpdates.sh w61 enu /makeiso /dotnet /msse /wddefs /nocleanup /proxy http://127.0.0.1:8080

läuft, nach laaaanger Zeit kommt dann
Code: Select all
#########################################################################
### WSUS Offline Update ISO maker for Linux systems ###
### v. 8.3 ###
### ###
### http://www.wsusoffline.net/ ###
### Authors: Stefan Joehnke, Walter Schiessberg ###
### maintained by H. Hullen ###
#########################################################################
language glb does not exist.

(man beachte: ich habe "enu" angefordert und "glb" wird angemeckert)

Dieselbe meldung kommt allerdings sofort, wenn ich anstelle "enu" "glb" eingebe.



Siehe (bei Version 8.3 und Nachfolgern) das Skript "commonparts.inc"; wenn Du dort nach "Setting language" suchst, dann siehst Du, dass die Sprache bei w60 bis (derzeit) w62 automatisch auf "glb" gesetzt wird. Aber die eingegebene Sprache muss in der Liste auftauchen.
Viele Grüsse
Helmut
hhullen
 
Posts: 100
Joined: 23.04.2012, 11:43

Re: CreateISOImage überarbeitet

Postby ronald » 10.04.2013, 17:27

Hallo

Achso ist das.

also noch mal anders gesagt (IIRC):

Ich gebe "enu" (w61) vor und bekomme -in der Phase des CD-bauens- die Fehlermeldung, das man "glb" nicht erkenne.
Da, wenn ich das richtig sehe, zwar einerseits wg. w61 das "enu" auf "glb" umgesetzt wird, aber andererseits das neue, gemeinsame
script "glb" (wegen der genaueren Prüfung) nicht (mehr) anerkennt, obwohl es bei w61 ff. durchaus erlaubt wäre?

Also funktioniertmein "Hack" mit dem zusätzlichen "glb", weil das neue script in 2 Zusammenhängen aufgerufen wird:
Einmal zu prüfen der Parameter, die der User vorgibt (download), und einmal für die Parameter die das Programm ermittelt hat (iso).
War das evtl. der Grund, warum es mal 2 fast gleiche Scripte gab?

Baust du da noch was ein, denn ganz offenbar ist nicht gewünscht das der User "glb" vorgibt?

Aber seltsam das nur ich drüber stolpere. Bin ich der einzige sonstige Linux-user? :-)
ronald
 
Posts: 7
Joined: 04.04.2013, 16:56

Re: CreateISOImage überarbeitet

Postby hhullen » 10.04.2013, 19:32

ronald wrote:Hallo

Achso ist das.

also noch mal anders gesagt (IIRC):

Ich gebe "enu" (w61) vor und bekomme -in der Phase des CD-bauens- die Fehlermeldung, das man "glb" nicht erkenne.
Da, wenn ich das richtig sehe, zwar einerseits wg. w61 das "enu" auf "glb" umgesetzt wird, aber andererseits das neue, gemeinsame
script "glb" (wegen der genaueren Prüfung) nicht (mehr) anerkennt, obwohl es bei w61 ff. durchaus erlaubt wäre?


Sorry - kann ich hier nicht reproduzieren.

Ich habe vorhin (wegen anderer Tests)

Code: Select all
bash DownloadUpdates.sh w61-x64 deu /nocleanup


laufen lassen - ist brav durchgelaufen.

Wenn ich jetzt

Code: Select all
bash CreateISOImage.sh w61-x64 deu /nocleanup


laufen lassen, dann kommt erst mal

Setting language to glb...
Creating ISO filter...
Writing builddate.txt...
Creating ISO image for w61-x64 glb...

und dann die ellenlange Liste von "mkisofs".
Viele Grüsse
Helmut
hhullen
 
Posts: 100
Joined: 23.04.2012, 11:43

Re: CreateISOImage überarbeitet

Postby ronald » 10.04.2013, 21:36

Thanks.

Ich lasse aber das "Paket" und das "iso" mit einem aufruf machen, Du hattest 2 calls gemacht
Parameter: /makeiso /dotnet /nocleanup /msse /wddefs

Evtl. wird dabei die Variable, die den User-Wert enthalten sollte, nun glb ist, also keine explizte Sprache?
Vermutlich gibt es da ein rekursions/reentrance problem.

Ich komm jetzt nicht an das Build-System, wohl erst Freitag wieder.
ronald
 
Posts: 7
Joined: 04.04.2013, 16:56

Re: CreateISOImage überarbeitet

Postby ronald » 10.04.2013, 21:47

hhullen wrote:und dann die ellenlange Liste von "mkisofs".

Ja, das wäre auch noch ein wunsch:
Kann mn das nicht ausschalten?
Es sitzt doch eh keiner davor und guckt sich das mkiso an, oder? :-)

Ich lass das image per cron bauen und bekomme dann immer eine mega mail von syslog, mit 99,999999% der Fortschritts-Zeilen vom mkisofs.
ronald
 
Posts: 7
Joined: 04.04.2013, 16:56

Re: CreateISOImage überarbeitet

Postby hhullen » 10.04.2013, 22:43

ronald wrote:Thanks.

Ich lasse aber das "Paket" und das "iso" mit einem aufruf machen, Du hattest 2 calls gemacht
Parameter: /makeiso /dotnet /nocleanup /msse /wddefs

Evtl. wird dabei die Variable, die den User-Wert enthalten sollte, nun glb ist, also keine explizte Sprache?
Vermutlich gibt es da ein rekursions/reentrance problem.

Ich komm jetzt nicht an das Build-System, wohl erst Freitag wieder.


Ja - ich ahne, wo das Problem sich verbirgt: die Sprache wird als einer der Parameter übergeben.

Da gehe ich aber jetzt nicht dran - jetzt ist Feierabend.

Und das Problem der angezeigten oder übergebenen Sprache taucht auch an anderen Stellen auf ...
Viele Grüsse
Helmut
hhullen
 
Posts: 100
Joined: 23.04.2012, 11:43

Next

Return to Linux

Who is online

Users browsing this forum: No registered users and 4 guests