Don't want Office packages

Don't want Office packages

Postby jelabarre » 12.10.2011, 22:37

In the v7.0 wsusoffline, using the shell scripts under Linux (Fedora), it insists on downloading the "ofc" packages, even though I have not asked for them. If I ask for wxp, or any other OS, it will try to give me "ofc" for the download. I don't want to DL any of the MSOffice packages (I will not provide support for MSO), and would prefer to get *only* those OS sets I request.
jelabarre
 

Re: Don't want Office packages

Postby bladerunner » 13.10.2011, 10:51

Hi jelabarre,

got bit yesterday by the same behaviour, and poked around in the script to find the problem. Turns out line 178 seems to be the culprit:

Code: Select all
if [ "$sys" == "o2k3" -o "$sys" == "o2k7" ]; then


I changed it to:

Code: Select all
if [ $sys == "o2k3" -o $sys == "o2k7" ]; then


as the if-statement seemed to always evaluate to true, so the $sys-variable got set to "ofc" two lines down the script. I have no idea why this statement should be special as the same syntax is used throughout the script, and does not seem to behave odd there...

Anyways, in my brief test I could not find any problem with the adapted syntax, and I have no time at hand to investigate the odd behaviour, so perhaps it fixes the problem for you too. YMMV.
bladerunner
 

Re: Don't want Office packages

Postby jelabarre » 13.10.2011, 19:48

I think it may be working, it at least doesn't show "ofc" as what it's downloading, but right now I can't tell if it's simply being slow, or the script has failed in a very quiet fashion.
jelabarre
 

Re: Don't want Office packages

Postby jelabarre » 27.10.2011, 22:04

Well, I'm guessing it's the latter. Making that modification definitely prevents it from downloading any MSOffice packages, because now the script doesn't download *anything*. It gets as far as "Determining update URLs for wxp enu..." and never goes any further. Looks like I'l lhave to wait for WSUSoffline v7.1 :(
jelabarre
 

Re: Don't want Office packages

Postby Denniss » 27.10.2011, 22:41

Please have a look at the changes to DownloadUpates.sh and CreateISOImage.sh made in trunkbuild 294 - this may fix the issue.
http://trac.wsusoffline.net/changeset/294
Last edited by aker on 28.07.2013, 18:54, edited 1 time in total.
Reason: Trac Link aktualisiert
Denniss
 
Posts: 865
Joined: 01.08.2009, 10:51

Re: Don't want Office packages

Postby jelabarre » 14.11.2011, 20:40

Got a chance to try the DownloadUpdates.sh from wsusoffline 7.1, and it still fails to run. I've tried with various package sets (wxp, w60-64, etc) and they all will hang at the same location. It's a separate issue from the Office package download problem, so I'll start a new thread with that.
jelabarre
 


Return to Linux

Who is online

Users browsing this forum: No registered users and 2 guests