Office 2013 wrong OS_ARCH for security fixes

Office 2013 wrong OS_ARCH for security fixes

Postby rbr555 » 12.08.2019, 13:30

Hello,

I can not apply security fixes for Office 2013.
The log shows x86 should be x64. The wrong selection starts after staitc updates:
Code: Select all
12.08.2019 14:04:25,82 - Info: Stopped service 'Windows Update' (wuauserv)
12.08.2019 14:04:29,97 - Warning: Installation of ..\w61-x64\glb\Windows6.1-KB2813956-x64.msu  failed (errorlevel: -2145124329)
12.08.2019 14:04:31,50 - Warning: Installation of ..\w61-x64\glb\Windows6.1-KB2732500-v2-x64.msu  failed (errorlevel: -2145124329)

...

12.08.2019 14:05:28,10 - Warning: Installation of ..\w61-x64\glb\Windows6.1-KB3181988-x64.msu  failed (errorlevel: -2145124329)
12.08.2019 14:05:30,87 - Warning: Installation of ..\w61-x64\glb\windows6.1-kb4100480-x64_8ee0dd707a58fb4fd089c4ac9e8c66403fce4421.msu  failed (errorlevel: -2145124329)
12.08.2019 14:05:40,58 - Warning: Installation of ..\o2k13\glb\osfclient2013-kb3039782-fullfile-x64-glb.exe failed (errorlevel: 17025 "Patch already installed")
12.08.2019 14:05:47,50 - Warning: Installation of ..\o2k13\glb\outlfltr2013-kb3114731-fullfile-x64-glb.exe failed (errorlevel: 17025 "Patch already installed")

...

12.08.2019 14:07:28,00 - Warning: Installation of ..\o2k13\glb\powerpoint2013-kb4018374-fullfile-x64-glb.exe failed (errorlevel: 17025 "Patch already installed")
12.08.2019 14:08:29,13 - Info: Installed ..\o2k13\glb\word2013-kb4475525-fullfile-x64-glb.exe
12.08.2019 14:08:31,85 - Warning: Installation of ..\o2k13\glb\excel2013-kb4464565-fullfile-x86-glb.exe failed (errorlevel: 17028 "No product installed for contained patch")
12.08.2019 14:08:32,81 - Warning: Installation of ..\o2k13\glb\graph2013-kb4464543-fullfile-x86-glb.exe failed (errorlevel: 17028 "No product installed for contained patch")
12.08.2019 14:08:35,40 - Warning: Installation of ..\o2k13\glb\lync2013-kb4475519-fullfile-x86-glb.exe failed (errorlevel: 17028 "No product installed for contained patch")
12.08.2019 14:08:36,29 - Warning: Installation of ..\o2k13\glb\osfclient2013-kb4018375-fullfile-x86-glb.exe failed (errorlevel: 17028 "No product installed for contained patch")
12.08.2019 14:08:38,66 - Warning: Installation of ..\o2k13\glb\outlook2013-kb4464592-fullfile-x86-glb.exe failed (errorlevel: 17028 "No product installed for contained patch")
12.08.2019 14:08:38,81 - Info: Installed 54 updates

At 12.08.2019 14:08:31,85 the wrong OS_ARCH is selcted x86 instead of x64.
kb4475525 is the last from
...\client\static\custom\StaticUpdateIds-o2k13.txt

Kind regards
Ronald
rbr555
 
Posts: 21
Joined: 04.01.2013, 12:00

Re: Office 2013 wrong OS_ARCH for security fixes

Postby Dalai » 12.08.2019, 15:47

Are you sure you have Office x64 installed? The architecture of the OS itself is independent from the architecture of MS Office! If you really have Office x64, you need to run wsusoffline\cmd\AddOffice2010x64Support.cmd before downloading updates.

Apart from that your system seems to have serious issues detecting and installing updates. Error -2145124329 in hex means FFFFFFFF80240017 which according to the Windows Update error code reference means
Code: Select all
0x80240017     WU_E_NOT_APPLICABLE     Operation was not performed because there are no applicable updates.
The question is: Why are there so many updates being installed that are not applicable?

Regards
Dalai
Dalai
 
Posts: 924
Joined: 12.07.2016, 21:00

Re: Office 2013 wrong OS_ARCH for security fixes

Postby aker » 12.08.2019, 16:06

Could you run .\client\cmd\DetermineSystemProperties.vbs and post the content of "WOUSystemProperties.txt", which is stored on your desktop.

Please also open a command prompt and enter
Code: Select all
set

Post the result here, too.
Wer Rechtschreibfehler findet, darf sie behalten oder an den Meistbietenden versteigern. / Everybody finding a misspelling is allowed to sell it.
aker
aker
 
Posts: 3345
Joined: 02.03.2011, 15:32
Location: %SystemRoot%\System32\Boot\winload.efi

Re: Office 2013 wrong OS_ARCH for security fixes

Postby rbr555 » 12.08.2019, 16:42

Hello,

I'm sure that I have Office x64 installed. E.g.:
Code: Select all
12.08.2019 14:08:29,13 - Info: Installed ..\o2k13\glb\word2013-kb4475525-fullfile-x64-glb.exe


Code: Select all
0x80240017     WU_E_NOT_APPLICABLE     Operation was not performed because there are no applicable updates.

If you try to install static Updates which are already applied or not needed than this error occurs.

The problem start with 11.7.4 with 11.7.2 it works fine.

Code: Select all
C:\Windows\system32>set
ALLUSERSPROFILE=C:\ProgramData
APPDATA=C:\Users\rbadmin\AppData\Roaming
CommonProgramFiles=C:\Program Files\Common Files
CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
CommonProgramW6432=C:\Program Files\Common Files
COMPUTERNAME=xxxxx
ComSpec=C:\Windows\system32\cmd.exe
FP_NO_HOST_CHECK=NO
HOMEDRIVE=M:
HOMEPATH=\
HOMESHARE=\\fileserver.xxxxx.de\home\xxxx
LOCALAPPDATA=C:\Users\xxxxx\AppData\Local
LOGONSERVER=\\xxxxx
NUMBER_OF_PROCESSORS=2
OS=Windows_NT
Path=C:\Program Files\AdoptOpenJDK\jdk-8.0.202.08\bin;C:\Program Files\AdoptOpenJDK\jdk-11.0.3.7-hotspot\bin;C:\Windows\syste
m32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\Windows System Resour
ce Manager\bin;;C:\Windows\idmu\common;C:\Program Files (x86)\SQL Anywhere 16\Bin32\;C:\Windows\system32;C:\Program Files\PuT
TY\
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
PROCESSOR_ARCHITECTURE=AMD64
PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 63 Stepping 2, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=3f02
ProgramData=C:\ProgramData
ProgramFiles=C:\Program Files
ProgramFiles(x86)=C:\Program Files (x86)
ProgramW6432=C:\Program Files
PROMPT=$P$G
PSModulePath=C:\Windows\system32\WindowsPowerShell\v1.0\Modules\
PUBLIC=C:\Users\Public
SQLANY16=C:\Program Files (x86)\SQL Anywhere 16\
SystemDrive=C:
SystemRoot=C:\Windows
TEMP=C:\Users\xxxxx\AppData\Local\Temp
TMP=C:\Users\xxxx\AppData\Local\Temp
USERDNSDOMAIN=xxxxx.DE
USERDOMAIN=xxxx
USERNAME=xxxx
USERPROFILE=C:\Users\xxxxx
windir=C:\Windows
windows_tracing_flags=3
windows_tracing_logfile=C:\BVTBin\Tests\installpackage\csilogfile.log


Code: Select all
set OS_VER_MAJOR=6
set OS_VER_MINOR=1
set OS_VER_BUILD=7601
set OS_VER_REVIS=24499
set OS_SP_VER_MAJOR=1
set OS_SP_VER_MINOR=0
set OS_LANG_CODE=0x407
set OS_LANG=deu
set OS_LANG_SHORT=de
set OS_LANG_EXT=de-de
set SystemDirectory=C:\Windows\system32
set OS_ARCH=x64
set OS_DOMAIN_ROLE=1
set OS_RAM_GB=8
set WU_START_MODE=Auto
set FS_TYPE=NTFS
set WUA_VER_MAJOR=7
set WUA_VER_MINOR=6
set WUA_VER_BUILD=7601
set WUA_VER_REVIS=24436
set MSI_VER_MAJOR=5
set MSI_VER_MINOR=0
set MSI_VER_BUILD=7601
set MSI_VER_REVIS=24460
set WSH_VER_MAJOR=5
set WSH_VER_MINOR=8
set WSH_VER_BUILD=9600
set WSH_VER_REVIS=19400
set IE_VER_MAJOR=9
set IE_VER_MINOR=11
set IE_VER_BUILD=9600
set IE_VER_REVIS=19399
set MSSL_VER_MAJOR=0
set MSSL_VER_MINOR=0
set MSSL_VER_BUILD=0
set MSSL_VER_REVIS=0
set DOTNET35_VER_MAJOR=3
set DOTNET35_VER_MINOR=5
set DOTNET35_VER_BUILD=30729
set DOTNET35_VER_REVIS=5420
set DOTNET4_VER_MAJOR=4
set DOTNET4_VER_MINOR=6
set DOTNET4_VER_BUILD=01055
set DOTNET4_VER_REVIS=0
set DOTNET4_RELEASE=394271
set PSH_VER_MAJOR=2
set PSH_VER_MINOR=0
set PSH_VER_BUILD=0
set PSH_VER_REVIS=0
set WMF_VER_MAJOR=0
set WMF_VER_MINOR=0
set WMF_VER_BUILD=0
set WMF_VER_REVIS=0
set MSSE_INSTALLED=1
set MSSE_VER_MAJOR=4
set MSSE_VER_MINOR=10
set MSSE_VER_BUILD=209
set MSSE_VER_REVIS=0
set MSSEDEFS_VER_MAJOR=1
set MSSEDEFS_VER_MINOR=299
set MSSEDEFS_VER_BUILD=1774
set MSSEDEFS_VER_REVIS=0
set NISDEFS_VER_MAJOR=119
set NISDEFS_VER_MINOR=0
set NISDEFS_VER_BUILD=0
set NISDEFS_VER_REVIS=0
set WD_INSTALLED=1
set WD_DISABLED=1
set WDDEFS_VER_MAJOR=1
set WDDEFS_VER_MINOR=95
set WDDEFS_VER_BUILD=191
set WDDEFS_VER_REVIS=0
set TSC_VER_MAJOR=6
set TSC_VER_MINOR=3
set TSC_VER_BUILD=9600
set TSC_VER_REVIS=16415
set QC_SET=1
set O2K13_VER_APP=Word
set O2K13_VER_MAJOR=15
set O2K13_VER_MINOR=0
set O2K13_VER_BUILD=5153
set O2K13_VER_REVIS=1000
set O2K13_SP_VER=1
set O2K13_ARCH=x64
set O2K13_LANG_CODE=0x407
set O2K13_LANG=deu
rbr555
 
Posts: 21
Joined: 04.01.2013, 12:00


Return to Installation / Updating

Who is online

Users browsing this forum: No registered users and 20 guests