problems of version 9.2.4 on WindowsXP

problems of version 9.2.4 on WindowsXP

Postby luweitest » 30.11.2018, 11:30

I have previously used 9.2.2 on Windows XP SP3 a year ago, performed downloading of updates, but did not perform any updates. I use online Microsoft update at that time. Recently I downloaded 9.2.4, and found that the bug about sigcheck still there:
Sigcheck 2.3 is the last version to run on XP, and -nobanner switch will cause error on 2.3.
So I edited DownloadUpdates.cmd, removed -nobanner switch, replaced sigcheck.exe with old 2.3 version, then downloading updates works fine.

Then after running UpdateGenerator.exe, no newer updates found (which should be), I ran UpdateInstaller.exe. First there are some errors with wmp11, powershell and an IE KB4018271, I checked log and it was registration failure. I tried running UpdateInstaller.exe with administrator account and it passed OK.

Then I run online Microsoft update to have a check, but instead of anticipation of no high level updates, it found 22 (my language is chs):

用于 Windows Server 2003 和 Windows XP x86 上的 Microsoft .NET Framework 2.0 SP2 的安全更新程序 (KB2898856)
用于 Windows Server 2003 和 Windows XP x86 上的 Microsoft .NET Framework 2.0 SP2 的安全更新程序 (KB2901111)
适用于 Windows Server 2003 和 Windows XP x86 的 Microsoft .NET Framework 2.0 SP2 安全更新 (KB2836941)
适用于 Windows XP、Server 2003、Vista 和 Server 2008 x86 的 Microsoft .NET Framework 3.5 SP1 更新 (KB2836940)
用于 Windows XP、Windows Server 2003、Windows Vista 和 Windows Server 2008 x86 的 Microsoft .NET Framework 3.5 SP1 安全更新程序 (KB2861697)
用于 Windows Server 2003 和 Windows XP x86 上的 Microsoft .NET Framework 2.0 SP2 的安全更新程序 (KB2863239)
用于 Windows Server 2003 和 Windows XP x86 上的 Microsoft .NET Framework 3.0 SP2 的安全更新程序 (KB2861189)
用于 Windows Server 2003 和 Windows XP x86 上的 Microsoft .NET Framework 2.0 SP2 的安全更新程序 (KB2844285)
用于 Windows Server 2003 和 Windows XP x86 上的 Microsoft .NET Framework 3.0 SP2 的安全更新程序 (KB2832411)
用于 Windows XP、Windows Server 2003、Windows Vista 和 Windows Server 2008 x86 的 Microsoft .NET Framework 3.5 SP1 安全更新程序 (KB2840629)
用于 Windows Server 2003 和 Windows XP x86 上的 Microsoft .NET Framework 2.0 SP2 的安全更新程序 (KB2789643)
用于 Windows Server 2003 和 Windows XP x86 上的 Microsoft .NET Framework 2.0 SP2 的安全更新程序 (KB2742596)
用于 Windows XP、Windows Server 2003、Windows Vista 和 Windows Server 2008 x86 的 Microsoft .NET Framework 3.5 SP1 安全更新程序 (KB2736416)
用于 Windows Server 2003 和 Windows XP x86 上的 Microsoft .NET Framework 3.0 SP2 的安全更新程序 (KB2756918)
用于 Windows Server 2003 和 Windows XP x86 上的 Microsoft .NET Framework 2.0 SP2 的安全更新程序 (KB2729450)
用于 Windows XP、Windows Server 2003、Windows Vista 和 Windows Server 2008 x86 的 Microsoft .NET Framework 3.5 SP1 安全更新程序 (KB2604111)
用于 Windows Server 2003 和 Windows XP x86 上的 Microsoft .NET Framework 2.0 SP2 的安全更新程序 (KB2604092)
Windows XP 安全更新程序 (KB2378111)
用于 Windows Server 2003 和 Windows XP x86 的 Microsoft .NET Framework 3.5 SP1 和 .NET Framework 2.0 SP2 更新程序 (KB982524)
用于 Windows Server 2003 和 Windows XP x86 的 Microsoft .NET Framework 3.5 SP1 更新程序 (KB982168)
Windows XP Service Pack 3 安全更新程序 (KB973540)
用于 .NET Framework Assistant 1.0 x86 的 .NET Framework 3.5 Service Pack 1 更新程序 (KB963707)

I wonder what caused this, and should I update.
luweitest
 
Posts: 3
Joined: 08.07.2017, 15:30

Re: problems of version 9.2.4 on WindowsXP

Postby Dalai » 30.11.2018, 16:42

luweitest wrote:Sigcheck 2.3 is the last version to run on XP, and -nobanner switch will cause error on 2.3.
So I edited DownloadUpdates.cmd, removed -nobanner switch, replaced sigcheck.exe with old 2.3 version, then downloading updates works fine.

This is a known issue, and it's easy to fix (if one knows how). Despite the recommendation download updates on Win7+, I download updates on XP myself. I doubt that there's going to be a fix for this particular issue in WSUS Offline because XP has been out of support for 4.5 years now, so it shouldn't be used anyway. WOU ESR edition was created because MS decided to release additional updates (Wannacry) after XP's support ended, but I don't think it's supposed to be really "long-term".

I tried running UpdateInstaller.exe with administrator account and it passed OK.

Well, to be able to install updates it's a requirement to run UpdateInstaller as administrator, isn't it?

Then I run online Microsoft update to have a check, but instead of anticipation of no high level updates, it found 22 (my language is chs):

It's completely normal that Windows Update finds additional updates after WSUS Offline Update is done. WOU's purpose is to install all security updates (that are in the Windows update catalog, wsusscn2.cab) before going online to reduce the risk of compromising the system. WOU is not able to install all available Windows updates, and even if it were, it would require extensive maintenance (that nobody is willing to do).

I wonder what caused this, and should I update.

Should update what? Install the updates found by Windows Update? Probably. But it would be even better to upgrade to a supported Windows version (Win7+).

Regards
Dalai
Last edited by Dalai on 01.12.2018, 04:09, edited 1 time in total.
Reason: Typo
Dalai
 
Posts: 651
Joined: 12.07.2016, 22:00

Re: problems of version 9.2.4 on WindowsXP

Postby luweitest » 01.12.2018, 03:28

Dalai wrote:This is a known issue, and it's easy to fix (if one knows how). Despite the recommendation download updates on Win7+, I download updates on XP myself. I doubt that there's going to be a fix for this particular issue in WSUS Offline because XP has been out of support for 4.5 years now, so it shouldn't be used anyway. WOU ESR edition was created because MS decided to release additional updates (Wnnacry) after XP's support ended, but I don't think it's supposed to be really "long-term".

It's completely normal that Windows Update finds additional updates after WSUS Offline Update is done. WOU's purpose is to install all security updates (that are in the Windows update catalog, wsusscn2.cab) before going online to reduce the risk of compromising the system. WOU is not able to install all available Windows updates, and even if it were, it would require extensive maintenance (that nobody is willing to do).


Thanks for the explanation. In fact I am somewhat surprised to see there's an ESR edition of WSUS Offline. Good work to people like me.

Should update what? Install the updates found by Windows Update? Probably. But it would be even better to upgrade to a supported Windows version (Win7+).


My computer is not powerful enough to run win7+, so I'd stick to XP until I change my laptop.
luweitest
 
Posts: 3
Joined: 08.07.2017, 15:30


Return to Installation / Updating

Who is online

Users browsing this forum: Google [Bot] and 18 guests