Patching Office 2010 within Crossover Linux

Patching Office 2010 within Crossover Linux

Postby Makaan » 02.08.2017, 13:59

I have three PCs two with WIn 10 and one with Fedora 26 where i have a Crossover Linux installation of Office 2010 for compatibility with my Win10 machines.
Is it possible to run the Updater within the Office 2010 Bottle of Crossover Linux?
What prerequisites does it need? .net ? c++ libs?
Makaan
 
Posts: 2
Joined: 02.08.2017, 13:56

Re: Patching Office 2010 within Crossover Linux

Postby Dalai » 02.08.2017, 16:31

Makaan wrote:Is it possible to run the Updater within the Office 2010 Bottle of Crossover Linux?

Most likely the UpdateInstaller itself will run, but apart from that it won't work because a Windows Update Agent won't be available.

What prerequisites does it need? .net ? c++ libs?

.NET is certainly not needed, I'm not sure if the UpdateInstaller needs C++ 2013, but a working Windows Update Agent is essential to be able to determine installed and missing updates. Since the latter is not available on such ABI layers updates can't be installed with any software that's based on WUA (like WSUS Offline, WSUS etc).

Regards
Dalai
Dalai
 
Posts: 331
Joined: 12.07.2016, 21:00

Re: Patching Office 2010 within Crossover Linux

Postby Makaan » 02.08.2017, 16:37

right, i forgot about that.
Do you have an idea how to somewhat automatize the patching?
Makaan
 
Posts: 2
Joined: 02.08.2017, 13:56

Re: Patching Office 2010 within Crossover Linux

Postby Dalai » 03.08.2017, 14:36

Unfortunately, no. I don't even know how updates for Office and/or other MS programs would be installed in an environment like Crossover. I mean, the update installation depends on something like WUA, DISM, WUSA or Windows Installer. Is any of them available on Crossover?

Regards
Dalai
Dalai
 
Posts: 331
Joined: 12.07.2016, 21:00


Return to Installation / Updating

Who is online

Users browsing this forum: Bing [Bot], hbuhrmester and 3 guests