Page 1 of 2

Problem with net framework reinstall

PostPosted: 21.01.2017, 18:51
by dubs
Hello, first off, thank you for creating and sharing WOU with us all for free. WOU made performing a clean install of Windows 10 so much easier!

Now I'm not sure if my problem is related to WOU directly, but I may as well ask.

When I used WOU originally I included the .net framework installer, and everything was fine until I tried playing a certain game. This game (Uthgard, a free server of Dark Age of Camelot) hasn't been able to load properly and I've gone through everything except reinstalling .net framework. When I went to look for .net framework in programs & features to uninstall it I couldn't find it anywhere. I'm guessing this is because I used WOU to install it and not directly from microsoft or windows update.

I first tried running the .net framework 4.6 file that I need to run this game to see if there was a uninstall or repair option, but it just said my version was up to date already. Next I looked around online and found framework verification tool, .net framework repair tool, and finally a .net framework cleanup tool. First I ran the repair tool and it said it was unable to fix it. Next I ran the cleanup tool, restarted, and tried to install version 4.6 again but it said my version was already up to date. Next I ran the verification tool and sure enough .net framework is still installed, the cleanup tool didn't seem to wipe it out.

So I'm not sure what to do next. I feel like it should be easier to uninstall .net framework, all the tutorials show it listed in programs & features. Did WOU install it in a different way? Any ideas how I can resolve this? Thanks in advance!

Re: Problem with net framework reinstall

PostPosted: 22.01.2017, 11:01
by aker
Windows 10 includes .NET Framework. So there is no special entry for it.
Reinstalling with the original installer or using the old repair tools won't work on newer revisions of Windows.

Re: Problem with net framework reinstall

PostPosted: 23.01.2017, 00:25
by dubs
Do you know where I could find the specific Windows Update KB2828152 that includes .net framework 4.5/4.6? When I go to Installed Updates under Programs & Features to look for it, the only updates that are visible are the ones I let Windows Update install after I used WOU.

Also when I ran the .net framework repair tool I got this message:

"The tool is unable to resolve the installation issues on your computer."
Code: Select all





C:\Users\Woody\AppData\Local\Temp\dd_NDP46-KB3045560-Web (1)_decompression_log.txt










































C:\Users\Woody\AppData\Local\Temp\Microsoft Visual C++ 2010  x64 Redistributable Setup_20161218_192335845-MSI_vc_red.msi.txt

C:\Users\Woody\AppData\Local\Temp\Microsoft Visual C++ 2010  x86 Redistributable Setup_20161217_141149729-MSI_vc_red.msi.txt

C:\Users\Woody\AppData\Local\Temp\Microsoft Visual C++ 2010  x86 Redistributable Setup_20161218_192329360-MSI_vc_red.msi.txt

C:\Users\Woody\AppData\Local\Temp\Microsoft Visual C++ 2010  x86 Redistributable Setup_20161223_160330950-MSI_vc_red.msi.txt

C:\Users\Woody\AppData\Local\Temp\Microsoft .NET Framework 4.5.1 Setup_20161217_140011043.html

C:\Users\Woody\AppData\Local\Temp\Microsoft .NET Framework 4.6 Setup_20170120_093611588.html

C:\Users\Woody\AppData\Local\Temp\Microsoft .NET Framework 4.6 Setup_20170120_165423503.html

C:\Users\Woody\AppData\Local\Temp\Microsoft .NET Framework 4.6 Setup_20170120_203311431.html

C:\Users\Woody\AppData\Local\Temp\Microsoft .NET Framework 4.6 Setup_20170120_203953845.html

C:\Users\Woody\AppData\Local\Temp\Microsoft .NET Framework 4.6 Setup_20170120_205536858.html

C:\Users\Woody\AppData\Local\Temp\Microsoft .NET Framework 4.6 Setup_20170120_205636564.html

C:\Users\Woody\AppData\Local\Temp\Microsoft .NET Framework 4.6 Setup_20170120_210838670.html

C:\Users\Woody\AppData\Local\Temp\Microsoft .NET Framework 4.6 Setup_20170120_215247469.html

C:\Users\Woody\AppData\Local\Temp\Microsoft .NET Framework 4.6 Setup_20170120_220834750.html

C:\Users\Woody\AppData\Local\Temp\Microsoft Visual C++ 2010  x64 Redistributable Setup_20161218_192335845.html

C:\Users\Woody\AppData\Local\Temp\Microsoft Visual C++ 2010  x86 Redistributable Setup_20161217_141149729.html

C:\Users\Woody\AppData\Local\Temp\Microsoft Visual C++ 2010  x86 Redistributable Setup_20161218_192329360.html

C:\Users\Woody\AppData\Local\Temp\Microsoft Visual C++ 2010  x86 Redistributable Setup_20161223_160330950.html



Re: Problem with net framework reinstall

PostPosted: 25.01.2017, 10:13
by aker
KB2828152 is an for .NET 4.6 and 4.6.1.
wsusou will update .NET to 4.6.2, which is newer than the specified update.
The update does not apply to .NET 4.5.x.

Re: Problem with net framework reinstall

PostPosted: 27.01.2017, 01:19
by dubs
So what am I supposed to do to fix my .net framework? Only option I see left is to reinstall Windows and NOT use WOU, which is unfortunate cause I really like the software.

Re: Problem with net framework reinstall

PostPosted: 27.01.2017, 09:09
by WSUSUpdateAdmin

You may

a) preinstall the old rootsupd.exe or
b) let WOU patch the OS, search for updates online (which causes the certs to be up to date) and let WOU install/patch .NET afterwards.

T. Wittrock

Re: [OT] Problem with net framework reinstall

PostPosted: 27.01.2017, 09:10
by aker
Then provide some info:
- Which version of Windows 10? (1507, 1511, 1607?) [Run "winver" to get this information].
- x86 or x64?
- Which game? And how old is it? [Maybe it is not compatible with .NET 4.6.x]
- Please run an administrative command prompt and enter
Code: Select all
sfc /scannow

What does it return?

Getting off-topic now...

Re: Problem with net framework reinstall

PostPosted: 29.01.2017, 01:38
by dubs
Appreciate the response guys, sorry if I'm not providing all the correct info. As you can tell I'm not very savvy with Windows.

I'm running Windows 10 x64, Version 1607.

The game I'm trying to get working requires .NET 4.6. The link they provide is to this ... x?id=48130 (which I've tried and it says I have a newer version installed).

It's a little complicated cause it's a free private server for the old mmo Dark Age of Camelot. The server launches from a web browser for some reason, which is kinda strange but they have reasons I guess. They also call for a specific C++ version (which I installed successfully). I made sure to try everything else I could think of before attempting to reinstall my .NET Framework. After running the repair tool and seeing it came up with a bunch of errors I'm guessing this is where the problem lies.

I ran the scan and got this message:

Code: Select all
Microsoft Windows [Version 10.0.14393]
(c) 2016 Microsoft Corporation. All rights reserved.

C:\Windows\system32>CODE: SELECT ALL
'CODE:' is not recognized as an internal or external command,
operable program or batch file.

C:\Windows\system32>sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection found corrupt files and successfully repaired
them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For
example C:\Windows\Logs\CBS\CBS.log. Note that logging is currently not
supported in offline servicing scenarios.


I checked the CBS.log and it is too long to post as a reply here, it goes over the character limit. Any other way I can show it to you?

Sorry T. Wittrock, you may have to dumb down your answer a bit for me. Not sure what the rootsupd.exe is and what you mean by preinstalling it. I may have to go with option B you listed, which means I have to reinstall all my drivers and crap too I think right?

Also, I tried a different program to check my .NET versions and got this result

Code: Select all


< Installed .NET Frameworks >
.NET FW 2.0 SP 2  (CLR:2.0)
.NET FW 3.0 SP 2  (CLR:2.0)
.NET FW 3.5 SP 1  (CLR:2.0)
.NET FW 4.6.2  (CLR:4.0)

< Installed Updates >
Microsoft .NET Framework 4 Client Profile
Microsoft .NET Framework 4 Extended

< Installed Languages 3.0>
English - United States
< Installed Languages 3.5.x>
English - United States
< Installed Languages 4.x>
English - United States

Re: Problem with net framework reinstall

PostPosted: 02.02.2017, 20:22
by aker
I'll take a look, if can provide you a link to the latest version of rootsupd.exe I have.
Just run it as admin.

.NET seems to be up2date as it automatically gets updated on Windows 10. Which version of C++ does the program require?

Re: Problem with net framework reinstall

PostPosted: 07.02.2017, 01:40
by dubs
You want me to run both of those programs? I'm not sure what rootsupd.exe is.

The game requires C++ 2015 x86.

This has been such a headache I think I'm going to just reinstall Windows and not use WOU to install .NET this time.