[solved] Error when running WSUS Offline Update 10.7.4

[solved] Error when running WSUS Offline Update 10.7.4

Postby Tonyhall37 » 20.09.2016, 09:38

Hi,

When using WSUS Offline Update 10.7.4 to patch a Windows 2008 R2 SP1 server I get the following error.

"Error 0# when calling C:\Windows\System32\cmd.exe;C:\Windows\Microsoft.NET\Framework\v4.0.30319 /D /C Update.cmd /verify in C:\temp\w61-x64.Server2008R2x64."

It looks to me like the command is not even executing.

What is wrong?

regards

tony
Last edited by aker on 20.09.2016, 17:45, edited 1 time in total.
Reason: marked as solved
Tonyhall37
 
Posts: 2
Joined: 20.09.2016, 09:29

Re: Error when running WSUS Offline Update 10.7.4

Postby Tonyhall37 » 20.09.2016, 16:07

Solved!

I had ComSpec set up as follows: "ComSpec=C:\Windows\System32\cmd.exe;C:\Windows\Microsoft.NET\Framework\v4.0.30319".

From Computer --> Properties --> System --> Advanced System Settings --> Environment Variables --> Select "ComSpec"

Then Click Edit and remove ";C:\Windows\Microsoft.NET\Framework\v4.0.30319".

Retry and it no longer produces the error (Error 0# when calling C:\Windows\System32\cmd.exe;C:\Windows\Microsoft.NET\Framework\v4.0.30319 /D /C Update.cmd /verify in C:\temp\w61-x64.Server2008R2x64) and starts to patch the server!

regards
Tonyhall37
 
Posts: 2
Joined: 20.09.2016, 09:29

Re: [solved] Error when running WSUS Offline Update 10.7.4

Postby boco » 20.09.2016, 23:20

The .NET additional string surely should go into %PATH%, not %COMSPEC%.
Microsoft update catalog: http://catalog.update.microsoft.com/v7/site/
Windows Install media download: https://support.microsoft.com/en-us/help/15088/windows-create-installation-media
boco
 
Posts: 2007
Joined: 24.11.2009, 18:00
Location: Germany


Return to Verschiedenes / Miscellaneous

Who is online

Users browsing this forum: No registered users and 7 guests