/instie10 installs Internet Explorer 11 [by design]

/instie10 installs Internet Explorer 11 [by design]

Postby LogicDaemon » 12.04.2016, 18:41

wsusoffline is 10.6.1 currently, it auto-checks for self-updates daily (via script), and also sets itself to Russian with
Code: Select all
cmd\RemoveGermanLanguageSupport.cmd
cmd\AddCustomLanguageSupport.cmd rus


Third time in 2 weeks I am starting it on freshly installed Win7 Pro 64-bit systems with command
Code: Select all
cmd\DoUpdate.cmd /nobackup /updatercerts /updatecpp /instdotnet35 /instdotnet4 /updatetsc /instie10 /autoreboot

And it installs IE11 instead of IE10.

I spotted as wsusoffline starts IE11 installer via command line, so it's not normal windows update.

Also, because I really don't want IE11 at all, I even
Code: Select all
REG ADD "HKLM\SOFTWARE\Microsoft\Internet Explorer\Setup\11.0" /v "DoNotAllowIE11" /t REG_DWORD /d 1 /f /reg:64

right after Windows install (before connecting to LAN).

Don't know how long ago it started but around half year ago it still installed IE10 as requested.
Last edited by LogicDaemon on 14.04.2016, 11:55, edited 1 time in total.
LogicDaemon
 
Posts: 23
Joined: 18.09.2010, 11:23

Re: /instie10 installs Internet Explorer 11 [possiblybug rep

Postby aker » 12.04.2016, 20:12

As MS will just support the most recent IE on the OSes since Feb-2016, wsusou will now install the most recent one. You may install IE10 manually and block wsusou's IE11 setup using "/skipieinst".

.\doc\history.txt wrote:[...]
--------------------------------------------------------------------------------
Version 10.4 -- 01.02.16
[...]
- Mandatory installation of most recent Internet Explorer on Windows Vista, 7 and Server 2008(R2) (x86/x64) systems (see https://www.microsoft.com/en-us/Windows ... IE-support)
[...]
--------------------------------------------------------------------------------
Version 10.5 -- 15.02.16
[...]
- UpdateInstaller script will now show popup information for mandatory installation of most recent Internet Explorer on Windows Vista, 7 and Server 2008(R2) (x86/x64) systems (Thanks to "Denniss")
[...]
--------------------------------------------------------------------------------
Version 10.6 -- 03.03.16
[...]
- DoUpdate.cmd script will now support "/skipieinst" switch to avoid mandatory installation of most recent Internet Explorer (Thanks to "Joe", "FrankH", "smeijer", "jbegarek", "mAsTa", "boco", "Denniss" and "aker")
- UpdateInstaller.ini file will now support "skipieinst" setting in [Installation] to control "/skipieinst" switch for DoUpdate.cmd script
- Fix: DoUpdate.cmd script will now only install most recent Internet Explorer if IE feature was not disabled before (Thanks to "Joe", "FrankH", "smeijer", "jbegarek", "mAsTa", "boco", "Denniss" and "aker")
[...]
Wer Rechtschreibfehler findet, darf sie behalten oder an den Meistbietenden versteigern. / Everybody finding a misspelling is allowed to sell it.
aker
aker
 
Posts: 3255
Joined: 02.03.2011, 15:32
Location: %SystemRoot%\System32\Boot\winload.efi

Postby LogicDaemon » 14.04.2016, 11:53

k, thx, missed that.
LogicDaemon
 
Posts: 23
Joined: 18.09.2010, 11:23


Return to Verschiedenes / Miscellaneous

Who is online

Users browsing this forum: No registered users and 1 guest